Mailing list archives outage
Incident Report for W3C
Resolved
This incident has been resolved.
Posted Aug 17, 2023 - 14:38 UTC
Investigating
We are currently investigating this issue.
Posted Aug 17, 2023 - 12:49 UTC
This incident affected: Email & Mailing Lists.